re = /(@\w+?)#(\d+)/m
str = 'Привет @Albamarvel#115! Как дела? Забань плиз @durov#322 пока не поздно'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end