$re = '/(@\w+?)#(\d+)/m';
$str = 'Привет @Albamarvel#115! Как дела? Забань плиз @durov#322 пока не поздно';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);