using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\>)(\d{4}\-\d{2}\-\d{2}T\d{2}\:\d{2}\:\d{2}Z)(?=<\/span)";
string input = @"<p><span data-date=""2019-05-10"" data-time=""19:00:00"" class=""discourse-local-date"" data-timezones=""Europe/Brussels"" data-timezone=""Europe/Berlin"" data-email-preview=""2019-05-10T17:00:00Z UTC"">2019-05-10T17:00:00Z</span> → <span data-date=""2019-05-10"" data-time=""22:00:00"" class=""discourse-local-date"" data-timezones=""Europe/Brussels"" data-timezone=""Europe/Berlin"" data-email-preview=""2019-05-10T20:00:00Z UTC"">2019-05-10T20:00:00Z</span><br>
<div class=""lightbox-wrapper""><div class=""meta"">
<span class=""filename"">HackSpace_by_Sugar_Ray_Banister.jpg</span><span class=""informations"">1596×771 993 KB</span><span class=""expand""></span>
</div></a></div></p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}