# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\>)(\d{4}\-\d{2}\-\d{2}T\d{2}\:\d{2}\:\d{2}Z)(?=<\/span)"
test_str = ("<p><span data-date=\"2019-05-10\" data-time=\"19:00:00\" class=\"discourse-local-date\" data-timezones=\"Europe/Brussels\" data-timezone=\"Europe/Berlin\" data-email-preview=\"2019-05-10T17:00:00Z UTC\">2019-05-10T17:00:00Z</span> → <span data-date=\"2019-05-10\" data-time=\"22:00:00\" class=\"discourse-local-date\" data-timezones=\"Europe/Brussels\" data-timezone=\"Europe/Berlin\" data-email-preview=\"2019-05-10T20:00:00Z UTC\">2019-05-10T20:00:00Z</span><br>\n"
"<div class=\"lightbox-wrapper\"><div class=\"meta\">\n"
"<span class=\"filename\">HackSpace_by_Sugar_Ray_Banister.jpg</span><span class=\"informations\">1596×771 993 KB</span><span class=\"expand\"></span>\n"
"</div></a></div></p>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.