package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(a+b+){10}`)
var str = `abababababababababab
aaaaaaaaaabababababababababab
aabbaabbaabbaabbaabbaabbaabbaabbaabbaabb`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}