re = /(a+b+){10}/m
str = 'abababababababababab
aaaaaaaaaabababababababababab
aabbaabbaabbaabbaabbaabbaabbaabbaabbaabb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end