$re = '/(a+b+){10}/m';
$str = 'abababababababababab
aaaaaaaaaabababababababababab
aabbaabbaabbaabbaabbaabbaabbaabbaabbaabb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);