import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{(?=((?:(?!\\{\\{|\\}\\})\\S)*+|\\S*)\\}\\})";
final String string = "I am very much new to java...{{envelope|func\"{{aa}}{{ds}}|{{abc.xyz}}\"}} and i want to know.... more. \n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}