re = /\{\{(?=((?:(?!\{\{|}})\S)*+|\S*)}})/
str = 'I am very much new to java...{{envelope|func"{{aa}}{{ds}}|{{abc.xyz}}"}} and i want to know.... more.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end