$re = '/\{\{(?=((?:(?!\{\{|}})\S)*+|\S*)}})/';
$str = 'I am very much new to java...{{envelope|func"{{aa}}{{ds}}|{{abc.xyz}}"}} and i want to know.... more.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);