using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+):(\w+)";
string substitution = @"$2 $1";
string input = @"
public static KLADEBOL10:Timagefont=LoadImageFont(KladebolUrl,10*2,ImageFontStyle);
public static MainChannel:TChannel=AllocChannel();
public void KeyCodeToString:String(Int keycode)
{
public void GetListByName:TList(string nm)
{";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}