using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(?<PreRef>[^\s\d]+):(?<Ref>\d{5})(?!\S)";
string input = @"This is a reference:12345
This is not a ref5rence:12345
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}