$re = '/(?<!\S)(?<PreRef>[^\s\d]+):(?<Ref>\d{5})(?!\S)/';
$str = 'This is a reference:12345
This is not a ref5rence:12345
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);