re = /(?<!\S)(?<PreRef>[^\s\d]+):(?<Ref>\d{5})(?!\S)/
str = 'This is a reference:12345
This is not a ref5rence:12345
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end