using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^abc\h*-\h*((?:[^\s-]+(?:\h+[^\s-]+)*)?)";
string input = @"abc - xyz
abc - pqr - xyz
abc - - xyz
abc - pqr uvw - xyz";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}