re = /^abc\h*-\h*((?:[^\s-]+(?:\h+[^\s-]+)*)?)/m
str = 'abc - xyz
abc - pqr - xyz
abc - - xyz
abc - pqr uvw - xyz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end