use strict;
my $str = '""00001","Open","2020-10-23 12:45","2022-10-20 15:48","Error not found","Alex Smith","NO ERROR","ErrorApp","FOB","CNSHA","GB","Plane","MODEL","2020-10-24 00:00","New","1","","2022-10-20 15:48""
';
my $regex = qr/^(\"(?:\"[^\"]*\",){3})\"[^\"]*\"|\"[^\"]*\"(\")$/mp;
my $subst = '$1""$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";