// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^((?:\"[^\"]*\",){3})\"[^\"]*\"|\"[^\"]*\"$"#).unwrap();
let string = "\"00001\",\"Open\",\"2020-10-23 12:45\",\"2022-10-20 15:48\",\"Error not found\",\"Alex Smith\",\"NO ERROR\",\"ErrorApp\",\"FOB\",\"CNSHA\",\"GB\",\"Plane\",\"MODEL\",\"2020-10-24 00:00\",\"New\",\"1\",\"\",\"2022-10-20 15:48\"
";
let substitution = "$1\"\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}