re = /[\(\)]/mi
str = 'жвадл (ы аы)ыва (dg dg dg (((( sdf (99
жвадл (ы аы)ыва (dg dg dg (((( sdf (99
жвадл (ы аы)ыва (dg dg dg (((( sdf (99
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end