package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{4}-M\d-)(\d{4})(-\d{4})`)
var str = `0124-M5-2260-1400
1225-M6-1015-1400
3023-M7-1005-1400`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}