// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{4}-M\d-)(\d{4})(-\d{4})").unwrap();
let string = "0124-M5-2260-1400
1225-M6-1015-1400
3023-M7-1005-1400";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}