import re
regex = re.compile(r"(\d{4}-M\d-)(\d{4})(-\d{4})", flags=re.MULTILINE)
test_str = ("0124-M5-2260-1400\n"
"1225-M6-1015-1400\n"
"3023-M7-1005-1400")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")