const regex = /(?=((\w)((?!\1)\w)\2))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=((\\w)((?!\\1)\\w)\\2))', 'g')
const str = `zazbz[bzb]cdb`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);