$re = '/(?=((\w)((?!\1)\w)\2))/';
$str = 'zazbz[bzb]cdb';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;