use strict;
my $str = 'zazbz[bzb]cdb';
my $regex = qr/(?=((\w)((?!\1)\w)\2))/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";