using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<name_of_new_field>.+?)\.";
string input = @"ir7utbws001.Feb-12-2016.043./dev/sdi
ir7mojavs12.Feb-12-2016.043./dev/sda1
Gcase-field-ogs-batch-004-staging.dec-12-2016.043
sb7sdamb002.Feb-12-2016.043./dev/sdn
ebase73-ist-bat-002.Feb-12-2016.043./dev/sda1
ik2itpcp002.Feb-12-2016.043./dev/sda1
ebase-field-ods-batch-003.Feb-12-2016.043./dev/sdi
Leo-batch-001.Feb-12-2016.043./dev/sda1 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}