# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<name_of_new_field>.+?)\."
test_str = ("ir7utbws001.Feb-12-2016.043./dev/sdi \n"
"ir7mojavs12.Feb-12-2016.043./dev/sda1 \n"
"Gcase-field-ogs-batch-004-staging.dec-12-2016.043 \n"
"sb7sdamb002.Feb-12-2016.043./dev/sdn \n"
"ebase73-ist-bat-002.Feb-12-2016.043./dev/sda1 \n"
"ik2itpcp002.Feb-12-2016.043./dev/sda1 \n"
"ebase-field-ods-batch-003.Feb-12-2016.043./dev/sdi \n"
"Leo-batch-001.Feb-12-2016.043./dev/sda1 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.