const regex = /^(?<name_of_new_field>.+?)\./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<name_of_new_field>.+?)\\.', 'gm')
const str = `ir7utbws001.Feb-12-2016.043./dev/sdi
ir7mojavs12.Feb-12-2016.043./dev/sda1
Gcase-field-ogs-batch-004-staging.dec-12-2016.043
sb7sdamb002.Feb-12-2016.043./dev/sdn
ebase73-ist-bat-002.Feb-12-2016.043./dev/sda1
ik2itpcp002.Feb-12-2016.043./dev/sda1
ebase-field-ods-batch-003.Feb-12-2016.043./dev/sdi
Leo-batch-001.Feb-12-2016.043./dev/sda1 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}