using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d\.\d{5})\d+";
string substitution = @"";
string input = @"-103.3751447563353";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}