$re = '/(?<=\d\.\d{5})\d+/';
$str = '-103.3751447563353';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;