const regex = /(?=<noteinfo).*(sequence='[0-9]'|sequence='[1-9][0-9]{0,3}')/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=<noteinfo).*(sequence=\'[0-9]\'|sequence=\'[1-9][0-9]{0,3}\')', 'gm')
const str = `<xmltag sequence='11'>
<noteinfo noteid='1fe' unid='25436AF06906885A8525840B00805DBC' sequence='3'/>
</xmltag>
<xmltag sequence='11'>
<noteinfo noteid='1fe' unid='25436AF06906885A8525840B00805DBC' sequence='9999'/>
</xmltag>
<xmltag sequence='11'>
<noteinfo noteid='1fe' unid='25436AF06906885A8525840B00805DBC' sequence='10000'/>
</xmltag>
<xmltag sequence='11'>
<noteinfo noteid='1fe' unid='25436AF06906885A8525840B00805DBC' sequence='-1'/>
</xmltag>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}