use strict;
my $str = '<xmltag sequence=\'11\'>
<noteinfo noteid=\'1fe\' unid=\'25436AF06906885A8525840B00805DBC\' sequence=\'3\'/>
</xmltag>
<xmltag sequence=\'11\'>
<noteinfo noteid=\'1fe\' unid=\'25436AF06906885A8525840B00805DBC\' sequence=\'9999\'/>
</xmltag>
<xmltag sequence=\'11\'>
<noteinfo noteid=\'1fe\' unid=\'25436AF06906885A8525840B00805DBC\' sequence=\'10000\'/>
</xmltag>
<xmltag sequence=\'11\'>
<noteinfo noteid=\'1fe\' unid=\'25436AF06906885A8525840B00805DBC\' sequence=\'-1\'/>
</xmltag>';
my $regex = qr/(?=<noteinfo).*(sequence='[0-9]'|sequence='[1-9][0-9]{0,3}')/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}