$re = '/(?=<noteinfo).*(sequence=\'[0-9]\'|sequence=\'[1-9][0-9]{0,3}\')/m';
$str = '<xmltag sequence=\'11\'>
<noteinfo noteid=\'1fe\' unid=\'25436AF06906885A8525840B00805DBC\' sequence=\'3\'/>
</xmltag>
<xmltag sequence=\'11\'>
<noteinfo noteid=\'1fe\' unid=\'25436AF06906885A8525840B00805DBC\' sequence=\'9999\'/>
</xmltag>
<xmltag sequence=\'11\'>
<noteinfo noteid=\'1fe\' unid=\'25436AF06906885A8525840B00805DBC\' sequence=\'10000\'/>
</xmltag>
<xmltag sequence=\'11\'>
<noteinfo noteid=\'1fe\' unid=\'25436AF06906885A8525840B00805DBC\' sequence=\'-1\'/>
</xmltag>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);