package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^F[A-Z]{0,2}$`)
var str = `F
FA
FB
FAA
FAAA
BF
BFA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}