$re = '/^F[A-Z]{0,2}$/m';
$str = 'F
FA
FB
FAA
FAAA
BF
BFA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);