using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(?![A-Z]+(?!\S))(?![0-9]+(?!\S))[a-zA-Z0-9_{}]+";
string input = @"ABC{hello}_HI_HelLo
ABC
123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}