re = /(?<!\S)(?![A-Z]+(?!\S))(?![0-9]+(?!\S))[a-zA-Z0-9_{}]+/m
str = 'ABC{hello}_HI_HelLo
ABC
123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end