$re = '/(?<!\S)(?![A-Z]+(?!\S))(?![0-9]+(?!\S))[a-zA-Z0-9_{}]+/m';
$str = 'ABC{hello}_HI_HelLo
ABC
123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);