const regex = /(?<=\p{L})-\h+(?=\p{L})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\p{L})-\\h+(?=\\p{L})', 'gm')
const str = `run- ning`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);