$re = '/(?<=\p{L})-\h+(?=\p{L})/m';
$str = 'run- ning';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;