use strict;
my $str = 'run- ning';
my $regex = qr/(?<=\p{L})-\h+(?=\p{L})/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";