#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=ce" content=")\d{6}(?=">)|(?<=hed" content=")[^"]*(?=">)"
Local $sString = "" & @CRLF & _
"<meta name="SAC:habitationType" content="1">" & @CRLF & _
" <meta name="SAC:price" content="444000">" & @CRLF & _
"<meta name="SAC:published" content="2020-03-28 11:06:22">" & @CRLF & _
"<meta name="SAC:listingType" content="1">" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")