import Foundation
let pattern = #"(?<=ce" content=")\d{6}(?=">)|(?<=hed" content=")[^"]*(?=">)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<meta name="SAC:habitationType" content="1">
<meta name="SAC:price" content="444000">
<meta name="SAC:published" content="2020-03-28 11:06:22">
<meta name="SAC:listingType" content="1">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)