re = /(?<=ce" content=")\d{6}(?=">)|(?<=hed" content=")[^"]*(?=">)/
str = '
<meta name="SAC:habitationType" content="1">
<meta name="SAC:price" content="444000">
<meta name="SAC:published" content="2020-03-28 11:06:22">
<meta name="SAC:listingType" content="1">
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end