package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)([0-9]{4}-[0-9]{2}-[0-9]{2}T[0-9]{2}:[0-9]{2}:[0-9]{2}\.[0-9]{3}) harvester chia.plotting.manager : INFO Found plot /wd(\d+)/chiaplot/plot-k32-([0-9]{4}-[0-9]{2}-[0-9]{2}-[0-9]{2}-[0-9]{2})-([a-fA-F0-9]{64}).plot of size (\d+)`)
var str = `2022-01-30T02:04:11.884 harvester chia.plotting.manager : INFO Found plot /wd03/chiaplot/plot-k32-2021-05-09-14-36-0d73f4050c20198e0e9809b978d142d183c14923ee02c401c20d83a0fa87de0c.plot of size 32`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}