import Foundation
let pattern = #"([0-9]{4}-[0-9]{2}-[0-9]{2}T[0-9]{2}:[0-9]{2}:[0-9]{2}\.[0-9]{3}) harvester chia.plotting.manager : INFO Found plot /wd(\d+)/chiaplot/plot-k32-([0-9]{4}-[0-9]{2}-[0-9]{2}-[0-9]{2}-[0-9]{2})-([a-fA-F0-9]{64}).plot of size (\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"2022-01-30T02:04:11.884 harvester chia.plotting.manager : INFO Found plot /wd03/chiaplot/plot-k32-2021-05-09-14-36-0d73f4050c20198e0e9809b978d142d183c14923ee02c401c20d83a0fa87de0c.plot of size 32"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)