import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{4}-[0-9]{2}-[0-9]{2}T[0-9]{2}:[0-9]{2}:[0-9]{2}\\.[0-9]{3}) harvester chia.plotting.manager : INFO Found plot /wd(\\d+)/chiaplot/plot-k32-([0-9]{4}-[0-9]{2}-[0-9]{2}-[0-9]{2}-[0-9]{2})-([a-fA-F0-9]{64}).plot of size (\\d+)";
final String string = "2022-01-30T02:04:11.884 harvester chia.plotting.manager : INFO Found plot /wd03/chiaplot/plot-k32-2021-05-09-14-36-0d73f4050c20198e0e9809b978d142d183c14923ee02c401c20d83a0fa87de0c.plot of size 32";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}