#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x).*\b(BLVD|BOULEVARD|DR(?:IVE)?|R(?:OA)?D|PL(?:ACE)?" & @CRLF & _
" |SL|CIRCLE|CT|COURT|WA?Y|ST(?:REET)?|AVE(?:NUE)?" & @CRLF & _
" |PKWY|(PARK)?:WAY|LN|LANE|HWY|HIGHWAY" & @CRLF & _
" |TRAIL$|CIR$)\b.*"
Local $sString = "AST SS BLVD" & @CRLF & _
"OUTH AA STREET" & @CRLF & _
"XX EAST ST" & @CRLF & _
"ZZ NORTH ROAD" & @CRLF & _
"EST TR TRAIL"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")