import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x).*\\b(BLVD|BOULEVARD|DR(?:IVE)?|R(?:OA)?D|PL(?:ACE)?\n"
+ " |SL|CIRCLE|CT|COURT|WA?Y|ST(?:REET)?|AVE(?:NUE)?\n"
+ " |PKWY|(PARK)?:WAY|LN|LANE|HWY|HIGHWAY\n"
+ " |TRAIL$|CIR$)\\b.*";
final String string = "AST SS BLVD\n"
+ "OUTH AA STREET\n"
+ "XX EAST ST\n"
+ "ZZ NORTH ROAD\n"
+ "EST TR TRAIL";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}