package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x).*\b(BLVD|BOULEVARD|DR(?:IVE)?|R(?:OA)?D|PL(?:ACE)?
|SL|CIRCLE|CT|COURT|WA?Y|ST(?:REET)?|AVE(?:NUE)?
|PKWY|(PARK)?:WAY|LN|LANE|HWY|HIGHWAY
|TRAIL$|CIR$)\b.*`)
var str = `AST SS BLVD
OUTH AA STREET
XX EAST ST
ZZ NORTH ROAD
EST TR TRAIL`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}